about summary refs log tree commit diff
path: root/packages/robloxenv/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'packages/robloxenv/default.nix')
-rw-r--r--packages/robloxenv/default.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/robloxenv/default.nix b/packages/robloxenv/default.nix
new file mode 100644
index 0000000..ca675e8
--- /dev/null
+++ b/packages/robloxenv/default.nix
@@ -0,0 +1,29 @@
+{ lib, python3 }:
+
+python3.pkgs.buildPythonApplication rec {
+  pname = "robloxenv";
+  src = ./robloxenv.py;
+  version = "0.1.0";
+  format = "other";
+
+  buildInputs = [ python3 ];
+  propagatedBuildInputs = with python3.pkgs; [
+    requests
+    click
+  ];
+
+  dontUnpack = true;
+  dontBuild = true;
+
+  installPhase = ''
+    mkdir -p $out/bin
+    cp $src $out/bin/${pname}
+  '';
+
+  meta = with lib; {
+    description = "This is a tool.";
+    license = with licenses; [ mit ];
+    platforms = platforms.unix;
+    maintainers = with maintainers; [ fcuny ];
+  };
+}