about summary refs log tree commit diff
path: root/packages/robloxenv/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <fcuny@roblox.com>2024-04-29 15:04:24 -0700
committerFranck Cuny <fcuny@roblox.com>2024-04-29 15:04:24 -0700
commitfb90e7296f00cd6a56ea77b5de81448135b71f63 (patch)
treeb1eb198e8b3e135c98faec4aaca4053c9cbb1683 /packages/robloxenv/default.nix
parentignore all of github.rbx.com (diff)
downloadworld-fb90e7296f00cd6a56ea77b5de81448135b71f63.tar.gz
add `robloxenv` to manage hashi credentials
I never know how to get the credentials for some hashi components.
This script helps with getting the credentials I need at the edge.
Diffstat (limited to 'packages/robloxenv/default.nix')
-rw-r--r--packages/robloxenv/default.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/robloxenv/default.nix b/packages/robloxenv/default.nix
new file mode 100644
index 0000000..ca675e8
--- /dev/null
+++ b/packages/robloxenv/default.nix
@@ -0,0 +1,29 @@
+{ lib, python3 }:
+
+python3.pkgs.buildPythonApplication rec {
+  pname = "robloxenv";
+  src = ./robloxenv.py;
+  version = "0.1.0";
+  format = "other";
+
+  buildInputs = [ python3 ];
+  propagatedBuildInputs = with python3.pkgs; [
+    requests
+    click
+  ];
+
+  dontUnpack = true;
+  dontBuild = true;
+
+  installPhase = ''
+    mkdir -p $out/bin
+    cp $src $out/bin/${pname}
+  '';
+
+  meta = with lib; {
+    description = "This is a tool.";
+    license = with licenses; [ mit ];
+    platforms = platforms.unix;
+    maintainers = with maintainers; [ fcuny ];
+  };
+}