about summary refs log tree commit diff
path: root/home/zsh/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/zsh/default.nix')
-rw-r--r--home/zsh/default.nix14
1 files changed, 13 insertions, 1 deletions
diff --git a/home/zsh/default.nix b/home/zsh/default.nix
index 392ccfc..0ee9e43 100644
--- a/home/zsh/default.nix
+++ b/home/zsh/default.nix
@@ -31,13 +31,25 @@ in {
         REPORTTIME = 5;
       };
 
-      shellAliases = { ll = "ls -l --color=auto"; };
+      shellAliases = {
+        ll = "ls -l --color=auto";
+        lt = "ls -ltrh --color=auto";
+        drone = "DRONE_TOKEN=$(pass api/drone.fcuny.xyz) drone";
+      };
 
       defaultKeymap = "emacs";
+
+      initExtraFirst = ''
+        if [ -z $DISPLAY ] && [ "$(tty)" = "/dev/tty1" ]; then
+          exec sway
+        fi
+      '';
+
       initExtra = lib.concatMapStrings builtins.readFile [
         ./completion-style.zsh
         ./options.zsh
         ./prompt.zsh
+        ./tmux.zsh
       ];
     };
   };