about summary refs log tree commit diff
path: root/home/zsh/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-05-16 19:15:54 -0700
committerFranck Cuny <franck@fcuny.net>2022-05-16 19:15:54 -0700
commita15a9c6c4d268f3cb667219c79778ff476ec0a5e (patch)
treedfdb9e7adf8084194a4362fafffba3903e3db997 /home/zsh/default.nix
parentbluetooh: enable on aptos (diff)
downloadworld-a15a9c6c4d268f3cb667219c79778ff476ec0a5e.tar.gz
zsh: manage tmux and start sway
If login, start sway. If tmux is not running, start it.
Diffstat (limited to 'home/zsh/default.nix')
-rw-r--r--home/zsh/default.nix14
1 files changed, 13 insertions, 1 deletions
diff --git a/home/zsh/default.nix b/home/zsh/default.nix
index 392ccfc..0ee9e43 100644
--- a/home/zsh/default.nix
+++ b/home/zsh/default.nix
@@ -31,13 +31,25 @@ in {
         REPORTTIME = 5;
       };
 
-      shellAliases = { ll = "ls -l --color=auto"; };
+      shellAliases = {
+        ll = "ls -l --color=auto";
+        lt = "ls -ltrh --color=auto";
+        drone = "DRONE_TOKEN=$(pass api/drone.fcuny.xyz) drone";
+      };
 
       defaultKeymap = "emacs";
+
+      initExtraFirst = ''
+        if [ -z $DISPLAY ] && [ "$(tty)" = "/dev/tty1" ]; then
+          exec sway
+        fi
+      '';
+
       initExtra = lib.concatMapStrings builtins.readFile [
         ./completion-style.zsh
         ./options.zsh
         ./prompt.zsh
+        ./tmux.zsh
       ];
     };
   };