about summary refs log tree commit diff
path: root/home/fish/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/fish/default.nix')
-rw-r--r--home/fish/default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/home/fish/default.nix b/home/fish/default.nix
new file mode 100644
index 0000000..1ba3d6c
--- /dev/null
+++ b/home/fish/default.nix
@@ -0,0 +1,13 @@
+{ config, lib, pkgs, ... }:
+let cfg = config.my.home.fish;
+in {
+  options.my.home.fish = with lib.my; {
+    enable = mkEnableOption "fish configuration";
+  };
+  config.programs.ssh = lib.mkIf cfg.enable {
+    enable = true;
+    interactiveShellInit = ''
+      set fish_greeting
+    '';
+  };
+}