about summary refs log tree commit diff
path: root/home/fish/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-04-07 08:31:05 -0700
committerFranck Cuny <franck@fcuny.net>2022-04-07 08:31:05 -0700
commitdcc0315bba21b4efde7ffc0a6e50af24fdd0fbb4 (patch)
treed8b5aa68afc302a116dafa26f74fcdf73587a8f2 /home/fish/default.nix
parentgitea: fix the module (diff)
downloadworld-dcc0315bba21b4efde7ffc0a6e50af24fdd0fbb4.tar.gz
initial attempt to reconfigure home-manager
All the modules that are needed for home-manager should be under
`home/`, and each host will have a `host.nix` where the modules are
enabled as needed. Later on we can create some profiles to make it
easier to consume the configuration.

I apply this only to tahoe for now, as the amount of packages needed for
my user are pretty limited.
Diffstat (limited to 'home/fish/default.nix')
-rw-r--r--home/fish/default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/home/fish/default.nix b/home/fish/default.nix
new file mode 100644
index 0000000..1ba3d6c
--- /dev/null
+++ b/home/fish/default.nix
@@ -0,0 +1,13 @@
+{ config, lib, pkgs, ... }:
+let cfg = config.my.home.fish;
+in {
+  options.my.home.fish = with lib.my; {
+    enable = mkEnableOption "fish configuration";
+  };
+  config.programs.ssh = lib.mkIf cfg.enable {
+    enable = true;
+    interactiveShellInit = ''
+      set fish_greeting
+    '';
+  };
+}