about summary refs log tree commit diff
path: root/modules/systems/software.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-02-08 16:32:56 -0800
committerFranck Cuny <franck@fcuny.net>2022-02-08 16:32:56 -0800
commit7376c608950648a65af8001b856a3dbf51d82023 (patch)
tree6665bc4710bae4020441211aacc43d62bb571b8d /modules/systems/software.nix
parenthome-manager: typo in my config (diff)
downloadworld-7376c608950648a65af8001b856a3dbf51d82023.tar.gz
systems: install more packages
Diffstat (limited to 'modules/systems/software.nix')
-rw-r--r--modules/systems/software.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/modules/systems/software.nix b/modules/systems/software.nix
new file mode 100644
index 0000000..59b6477
--- /dev/null
+++ b/modules/systems/software.nix
@@ -0,0 +1,22 @@
+{pkgs, config, lib, ...}:
+
+{
+  environment.systemPackages = with pkgs; [
+    curl
+    git
+    htop
+    hwdata
+    iftop
+    iptraf-ng
+    lm_sensors
+    mg
+    parted
+    parted
+    pciutils
+    rsync
+    strace
+    tcpdump
+    tmux
+    unzip
+  ]
+}