about summary refs log tree commit diff
path: root/modules/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-09-24 12:50:38 -0700
committerFranck Cuny <franck@fcuny.net>2022-09-24 12:50:38 -0700
commit02a6cd084e6746f989684449495f5ee1c901d402 (patch)
treea3c81e502e9a970dfc273789eced5a3dbadd9616 /modules/default.nix
parentfix(home/shell): set value for PKG_CONFIG_PATH (diff)
downloadworld-02a6cd084e6746f989684449495f5ee1c901d402.tar.gz
fix(modules/home): delete the module
The configuration for home-manager is set using `home-manager' directly,
instead of applying updates all at once (OS and home-manager).
Diffstat (limited to 'modules/default.nix')
-rw-r--r--modules/default.nix9
1 files changed, 1 insertions, 8 deletions
diff --git a/modules/default.nix b/modules/default.nix
index 0885f69..96e66fb 100644
--- a/modules/default.nix
+++ b/modules/default.nix
@@ -1,7 +1,7 @@
 { lib, ... }:
 
 {
-  imports = [ ./hardware ./system ./services ./home ./programs ./secrets ];
+  imports = [ ./hardware ./system ./services ./programs ./secrets ];
 
   options.my = with lib; {
     user = {
@@ -11,13 +11,6 @@
         example = "franck";
         description = "my username";
       };
-
-      home = {
-        enable = mkEnableOption {
-          description = "home-manager configuration";
-          default = true;
-        };
-      };
     };
   };
 }