about summary refs log tree commit diff
path: root/hosts/common/system/default.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-04-05 19:31:27 -0700
committerFranck Cuny <franck@fcuny.net>2022-04-05 19:31:27 -0700
commit4f5ccfb7924820cf0bb51a1f5f6a8697cebd58da (patch)
tree8a7ad0ec1c744733c6db40f824734851286fb15c /hosts/common/system/default.nix
parentmove locale configuration to a module (diff)
downloadworld-4f5ccfb7924820cf0bb51a1f5f6a8697cebd58da.tar.gz
refactor default packages to a module
Diffstat (limited to 'hosts/common/system/default.nix')
-rw-r--r--hosts/common/system/default.nix13
1 files changed, 2 insertions, 11 deletions
diff --git a/hosts/common/system/default.nix b/hosts/common/system/default.nix
index fda467f..2b48e4e 100644
--- a/hosts/common/system/default.nix
+++ b/hosts/common/system/default.nix
@@ -1,15 +1,6 @@
 { pkgs, ... }:
 
 {
-  imports = [
-    ./boot.nix
-    ./hardware.nix
-    ./network.nix
-    ./security.nix
-    ./software.nix
-    ./users.nix
-  ];
-
-  # It's always useful to have bash around
-  environment.shells = [ pkgs.bashInteractive pkgs.zsh pkgs.fish ];
+  imports =
+    [ ./boot.nix ./hardware.nix ./network.nix ./security.nix ./users.nix ];
 }