about summary refs log tree commit diff
path: root/users/fcuny/trusted/pass.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/fcuny/trusted/pass.nix')
-rw-r--r--users/fcuny/trusted/pass.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/users/fcuny/trusted/pass.nix b/users/fcuny/trusted/pass.nix
new file mode 100644
index 0000000..a552318
--- /dev/null
+++ b/users/fcuny/trusted/pass.nix
@@ -0,0 +1,35 @@
+{ pkgs, config, ... }:
+
+{
+  programs.password-store = {
+    enable = true;
+    settings = {
+      PASSWORD_STORE_DIR = "${config.xdg.dataHome}/password-store";
+      PASSWORD_STORE_GENERATED_LENGTH = "30";
+      PASSWORD_STORE_CHARACTER_SET = "a-zA-Z0-9~!@#$%^&*()-_=+[]{};:,.<>?";
+      PASSWORD_STORE_KEY = config.programs.gpg.settings.default-key;
+    };
+  };
+
+  programs.git = {
+    signing = {
+      key = config.programs.gpg.settings.default-key;
+      signByDefault = true;
+    };
+    extraConfig = {
+      credential = {
+        helper = "${pkgs.gitAndTools.pass-git-helper}/bin/pass-git-helper";
+        useHttpPath = true;
+      };
+    };
+  };
+
+  xdg.configFile."pass-git-helper/git-pass-mapping.ini" = {
+    source = ./git-pass-mapping.ini;
+  };
+
+  services.password-store-sync.enable = true;
+
+  # Ensure the password store things are in the systemd session
+  systemd.user.sessionVariables = config.programs.password-store.settings;
+}