about summary refs log tree commit diff
path: root/users/fcuny/desktop/xdg.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/fcuny/desktop/xdg.nix')
-rw-r--r--users/fcuny/desktop/xdg.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/users/fcuny/desktop/xdg.nix b/users/fcuny/desktop/xdg.nix
new file mode 100644
index 0000000..7390811
--- /dev/null
+++ b/users/fcuny/desktop/xdg.nix
@@ -0,0 +1,18 @@
+{ config, lib, pkgs, ... }:
+
+{
+  xdg.enable = true;
+
+  xdg.userDirs = {
+    enable = true;
+    createDirectories = true;
+    desktop = "\$HOME/documents";
+    documents = "\$HOME/documents";
+    download = "\$HOME/downloads";
+    music = "\$HOME/media/music";
+    pictures = "\$HOME/media/pictures";
+    publicShare = "\$HOME/documents/public";
+    templates = "\$HOME/documents/templates";
+    videos = "\$HOME/media/videos";
+  };
+}