about summary refs log tree commit diff
path: root/users/fcuny/desktop/sway/i3status.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/fcuny/desktop/sway/i3status.nix')
-rw-r--r--users/fcuny/desktop/sway/i3status.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/users/fcuny/desktop/sway/i3status.nix b/users/fcuny/desktop/sway/i3status.nix
new file mode 100644
index 0000000..9eb5733
--- /dev/null
+++ b/users/fcuny/desktop/sway/i3status.nix
@@ -0,0 +1,36 @@
+{ pkgs, ... }:
+
+{
+  programs.i3status-rust = {
+    enable = true;
+    bars.default = {
+      settings.theme.name = "plain";
+      icons = "awesome5";
+      blocks = [
+        {
+          block = "net";
+          format = "{ssid} {signal_strength} {ip}";
+          interval = 5;
+        }
+        {
+          block = "battery";
+          interval = 30;
+          format = "{percentage} {time}";
+        }
+        {
+          block = "backlight";
+        }
+        {
+          block = "sound";
+          on_click = "${pkgs.pavucontrol}/bin/pavucontrol";
+        }
+        {
+          block = "time";
+          interval = 1;
+          format = "%b-%d %H:%M:%S";
+          icons_format = "";
+        }
+      ];
+    };
+  };
+}