about summary refs log tree commit diff
path: root/users/fcuny/desktop/media/sync-videos.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/fcuny/desktop/media/sync-videos.nix')
-rw-r--r--users/fcuny/desktop/media/sync-videos.nix29
1 files changed, 0 insertions, 29 deletions
diff --git a/users/fcuny/desktop/media/sync-videos.nix b/users/fcuny/desktop/media/sync-videos.nix
deleted file mode 100644
index ced319d..0000000
--- a/users/fcuny/desktop/media/sync-videos.nix
+++ /dev/null
@@ -1,29 +0,0 @@
-{ config, pkgs, ... }:
-
-{
-  systemd.user.services.sync-videos = {
-    Unit = {
-      Description = "synchronize my videos to the NAS";
-      Documentation = "man:rsync(1)";
-      ConditionFileIsExecutable = "${pkgs.rsync}/bin/rsync";
-    };
-    Service = {
-      Type = "oneshot";
-      ExecStart = "${pkgs.rsync}/bin/rysnc -avz -t %h/media/videos/ nas.home:/data/videos/incoming";
-    };
-  };
-
-  systemd.user.timers.sync-videos = {
-    Unit = {
-      Description = "synchronize my videos to the NAS";
-      Documentation = "man:rsync(1)";
-    };
-    Timer = {
-      OnBootSec = "120m";
-      OnUnitActiveSec = "1d";
-      RandomizedDelaySec = "1800";
-      Persistent = true;
-    };
-    Install = { WantedBy = [ "timers.target" ]; };
-  };
-}