about summary refs log tree commit diff
path: root/users/fcuny/desktop/gtk.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/fcuny/desktop/gtk.nix')
-rw-r--r--users/fcuny/desktop/gtk.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/users/fcuny/desktop/gtk.nix b/users/fcuny/desktop/gtk.nix
new file mode 100644
index 0000000..492c331
--- /dev/null
+++ b/users/fcuny/desktop/gtk.nix
@@ -0,0 +1,36 @@
+{ config, lib, pkgs, ... }:
+
+{
+  # This is required for the gtk configuration below
+  home.packages = [
+    pkgs.gnome3.dconf
+  ];
+
+  gtk = {
+    enable = true;
+    theme.name = "Adwaita";
+    iconTheme = {
+      name = "Adwaita";
+      package = pkgs.gnome3.adwaita-icon-theme;
+    };
+
+    gtk2 = {
+      extraConfig = ''
+        gtk-application-prefer-dark-theme = true
+        gtk-xft-antialias = 1
+        gtk-xft-hinting = 1
+        gtk-xft-hintstyle = "hintslight"
+        gtk-cursor-theme-size = cursorSize
+      '';
+    };
+
+    gtk3 = {
+      extraConfig = {
+        gtk-application-prefer-dark-theme = true;
+        gtk-xft-antialias = 1;
+        gtk-xft-hinting = 1;
+        gtk-xft-hintstyle = "hintslight";
+      };
+    };
+  };
+}