about summary refs log tree commit diff
path: root/users/fcuny/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/fcuny/default.nix')
-rw-r--r--users/fcuny/default.nix21
1 files changed, 5 insertions, 16 deletions
diff --git a/users/fcuny/default.nix b/users/fcuny/default.nix
index 9d2f194..755f59e 100644
--- a/users/fcuny/default.nix
+++ b/users/fcuny/default.nix
@@ -1,12 +1,11 @@
-{ config, lib, pkgs, ... }:
+{ config, lib, pkgs, desktop, ... }:
 
 {
-  programs.home-manager.enable = true;
+  imports =
+    [./cli ]
+    ++ (if desktop then [./desktop] else [ ]);
 
-  home.packages = [
-    pkgs.jq
-    pkgs.ripgrep
-  ];
+  programs.home-manager.enable = true;
 
   home.sessionVariables = {
     LANG = "en_US.UTF-8";
@@ -14,14 +13,4 @@
     LC_ALL = "en_US.UTF-8";
     EDITOR = "vim";
   };
-
-  imports = [
-    ../common/desktop
-    ./git.nix
-    ./go.nix
-    ./tmux.nix
-    ./zsh.nix
-    ./desktop.nix
-    ./pass.nix
-  ];
 }