about summary refs log tree commit diff
path: root/users/fcuny/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/fcuny/common.nix')
-rw-r--r--users/fcuny/common.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/users/fcuny/common.nix b/users/fcuny/common.nix
new file mode 100644
index 0000000..04bc1c1
--- /dev/null
+++ b/users/fcuny/common.nix
@@ -0,0 +1,20 @@
+{ config, lib, pkgs ... }
+
+{
+  home.packages = [
+    pkgs.jq
+    pkgs.ripgrep
+  ];
+
+  home.sessionVariables = {
+    LANG = "en_US.UTF-8";
+    LC_CTYPE = "en_US.UTF-8";
+    LC_ALL = "en_US.UTF-8";
+    EDITOR = "vim";
+  };
+
+  programs.go = {
+    enable = true;
+    goPath = "workspace/go";
+  };
+}