about summary refs log tree commit diff
path: root/users/fcuny/common.nix
diff options
context:
space:
mode:
authorFranck Cuny <franck@fcuny.net>2022-02-09 08:25:51 -0800
committerFranck Cuny <franck@fcuny.net>2022-02-09 08:25:51 -0800
commit52ef45715fa2501db36980089df5d89a2d473529 (patch)
treeb13f10b8eebb6ba1bafe0ce8ead4cf9360df6123 /users/fcuny/common.nix
parentRevert "desktop: new option to control desktop setup" (diff)
downloadworld-52ef45715fa2501db36980089df5d89a2d473529.tar.gz
home-manager: simplify the configuration
I'm still struggling with documentation, and I'd rather have something
simple that works rather than smart and does not work.

The configuration for the host imports the modules that are relevant to
that host (in the case of carmel, desktop and systems).

For the home-manager, I create a profile "desktop" that contains stuff
related to a desktop (i3, etc), and it includes the module "common" that
contains stuff that I want on any machines (so that in the future, for
a machine that is a server, the home manager will only import "common").
Diffstat (limited to 'users/fcuny/common.nix')
-rw-r--r--users/fcuny/common.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/users/fcuny/common.nix b/users/fcuny/common.nix
new file mode 100644
index 0000000..04bc1c1
--- /dev/null
+++ b/users/fcuny/common.nix
@@ -0,0 +1,20 @@
+{ config, lib, pkgs ... }
+
+{
+  home.packages = [
+    pkgs.jq
+    pkgs.ripgrep
+  ];
+
+  home.sessionVariables = {
+    LANG = "en_US.UTF-8";
+    LC_CTYPE = "en_US.UTF-8";
+    LC_ALL = "en_US.UTF-8";
+    EDITOR = "vim";
+  };
+
+  programs.go = {
+    enable = true;
+    goPath = "workspace/go";
+  };
+}