about summary refs log tree commit diff
path: root/users/fcuny/cli/zsh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/fcuny/cli/zsh.nix')
-rw-r--r--users/fcuny/cli/zsh.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/users/fcuny/cli/zsh.nix b/users/fcuny/cli/zsh.nix
new file mode 100644
index 0000000..6b56d35
--- /dev/null
+++ b/users/fcuny/cli/zsh.nix
@@ -0,0 +1,21 @@
+{config, lib, pkgs, ...}:
+
+{
+
+  xdg.configFile."zsh/personal".source = config.lib.file.mkOutOfStoreSymlink ../../configs/zsh;
+
+  programs.zsh = {
+    enable = true;
+    enableAutosuggestions = true;
+    enableCompletion = true;
+    defaultKeymap = "emacs";
+    history = {
+      save = 100000;
+      extended = true;
+      ignoreDups = true;
+    };
+    initExtra = ''
+      source ${config.xdg.configHome}/zsh/personal/init.zsh
+    '';
+  };
+}