about summary refs log tree commit diff
path: root/users/fcuny/cli/ssh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/fcuny/cli/ssh.nix')
-rw-r--r--users/fcuny/cli/ssh.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/users/fcuny/cli/ssh.nix b/users/fcuny/cli/ssh.nix
new file mode 100644
index 0000000..9708660
--- /dev/null
+++ b/users/fcuny/cli/ssh.nix
@@ -0,0 +1,17 @@
+{
+  programs.ssh = {
+    enable = true;
+    forwardAgent = true;
+    serverAliveInterval = 60;
+    controlMaster = "auto";
+    controlPersist = "30m";
+    matchBlocks = {
+      "github.com" = {
+        hostname = "github.com";
+        user = "git";
+        forwardAgent = false;
+        extraOptions = { preferredAuthentications = "publickey"; };
+      };
+    };
+  };
+}