about summary refs log tree commit diff
path: root/users/fcuny/cli/git.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/fcuny/cli/git.nix')
-rw-r--r--users/fcuny/cli/git.nix14
1 files changed, 4 insertions, 10 deletions
diff --git a/users/fcuny/cli/git.nix b/users/fcuny/cli/git.nix
index 30ee841..8afb7ec 100644
--- a/users/fcuny/cli/git.nix
+++ b/users/fcuny/cli/git.nix
@@ -1,6 +1,7 @@
-{ config, ... }:
+{ lib, config, ... }:
 
-{
+let inherit (lib) mkIf;
+in {
   programs.git = {
     enable = true;
     aliases = {
@@ -17,16 +18,9 @@
     };
     userName = "Franck Cuny";
     userEmail = "franck@fcuny.net";
-    signing = {
-      key = config.programs.gpg.settings.default-key;
-      signByDefault = true;
-    };
     extraConfig = {
       "credential \"https://github.com\"" = { username = "fcuny"; };
-      "credential \"https://git.fcuny.net\"" = {
-        username = "fcuny";
-        helper = "!echo -n 'password='; pass git/git.fcuny.net";
-      };
+      "credential \"https://git.fcuny.net\"" = { username = "fcuny"; };
     };
     ignores = [
       "*.elc"