about summary refs log tree commit diff
path: root/users/fcuny/cli/backups.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/fcuny/cli/backups.nix')
-rw-r--r--users/fcuny/cli/backups.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/users/fcuny/cli/backups.nix b/users/fcuny/cli/backups.nix
index 2c5c05b..7edbc59 100644
--- a/users/fcuny/cli/backups.nix
+++ b/users/fcuny/cli/backups.nix
@@ -4,4 +4,20 @@
   home.packages = with pkgs; [
     restic
   ];
+
+  systemd.user.services.backup = {
+    Unit = {
+      Description = "backup my home directory";
+      Documentation = "man:resitc(1)";
+    };
+    Service = {
+      Type = "oneshot";
+      Environment = [
+        "RESTIC_REPOSITORY=rest:http://192.168.6.10:8010/"
+        "RESTIC_PASSWORD_COMMAND=\"pass backup/restic@%H\""
+      ];
+      ExecStartPre = "${pkgs.systemd}/lib/systemd/systemd-networkd-wait-online --interface=wg0";
+      ExecStart = "${pkgs.restic}/bin/restic --tag=home-nixos --exclude=%h/media --exclude=%C --exclude=%E backup %h";
+    };
+  };
 }