about summary refs log tree commit diff
path: root/users/fcuny/blog/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/fcuny/blog/flake.nix')
-rw-r--r--users/fcuny/blog/flake.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/users/fcuny/blog/flake.nix b/users/fcuny/blog/flake.nix
index 35ada07..7d5a4b2 100644
--- a/users/fcuny/blog/flake.nix
+++ b/users/fcuny/blog/flake.nix
@@ -10,6 +10,18 @@
     flake-utils.lib.eachDefaultSystem (system:
       let pkgs = nixpkgs.legacyPackages.${system};
       in {
+        defaultPackage = with pkgs;
+          stdenv.mkDerivation {
+            pname = "fcuny.net";
+            version = self.lastModifiedDate;
+            src = ./.;
+            buildInputs = [ hugo git ];
+            buildPhase = ''
+              mkdir -p $out
+              hugo --minify --destination $out
+            '';
+            dontInstall = true;
+          };
         defaultApp = pkgs.writers.writeBashBin "run-hugo" ''
           set -e
           set -o pipefail
@@ -17,6 +29,15 @@
           hugo server -D
         '';
 
+        deploy = pkgs.writers.writeBashBin "run-deploy" ''
+          set -e
+          set -o pipefile
+          export PATH=${
+            pkgs.lib.makeBinPath [ pkgs.hugo pkgs.git pkgs.jq pkgs.flyctl ]
+          }
+          ./scripts/deploy.sh
+        '';
+
         devShell =
           pkgs.mkShell { buildInputs = with pkgs; [ hugo flyctl git jq ]; };
       });