about summary refs log tree commit diff
path: root/users/fcuny/blog/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/fcuny/blog/default.nix')
-rw-r--r--users/fcuny/blog/default.nix30
1 files changed, 0 insertions, 30 deletions
diff --git a/users/fcuny/blog/default.nix b/users/fcuny/blog/default.nix
deleted file mode 100644
index 8c817f5..0000000
--- a/users/fcuny/blog/default.nix
+++ /dev/null
@@ -1,30 +0,0 @@
-{ pkgs, ... }:
-
-pkgs.stdenv.mkDerivation rec {
-  name = "fcuny.net";
-
-  src = ./.;
-
-  nativeBuildInputs = [ pkgs.hugo pkgs.git ];
-
-  installPhase = ''
-    mkdir -p $out
-    ${pkgs.hugo}/bin/hugo --minify -d $out/
-  '';
-
-  server = pkgs.writers.writeBashBin "run-server" ''
-    set -ueo pipefail
-    cd $(git rev-parse --show-toplevel)
-    cd users/fcuny/blog
-    export PATH=${pkgs.lib.makeBinPath [ pkgs.hugo pkgs.git ]}
-    hugo server -D
-  '';
-
-  meta = with pkgs.lib; {
-    description = "franck cuny's blog";
-    homepage = "https://fcuny.net";
-    license = licenses.mit;
-    platforms = platforms.linux;
-    maintainers = [ ];
-  };
-}