about summary refs log tree commit diff
path: root/tools/seqstat/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/seqstat/default.nix')
-rw-r--r--tools/seqstat/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/tools/seqstat/default.nix b/tools/seqstat/default.nix
new file mode 100644
index 0000000..d45f4bf
--- /dev/null
+++ b/tools/seqstat/default.nix
@@ -0,0 +1,24 @@
+{ self, lib, python3, stdenvNoCC, pkgs }:
+
+stdenvNoCC.mkDerivation rec {
+  pname = "seqstat";
+  src = ./seqstat.py;
+  version = "0.1.0";
+
+  buildInputs = [ python3 ];
+
+  dontUnpack = true;
+  dontBuild = true;
+
+  installPhase = ''
+    mkdir -p $out/bin
+    cp $src $out/bin/${pname}
+  '';
+
+  meta = with lib; {
+    description = "Display an histogram for a given sequence of numbers.";
+    license = with licenses; [ mit ];
+    platforms = platforms.unix;
+    maintainers = with maintainers; [ fcuny ];
+  };
+}