about summary refs log tree commit diff
path: root/profiles/workstation.nix
diff options
context:
space:
mode:
Diffstat (limited to 'profiles/workstation.nix')
-rw-r--r--profiles/workstation.nix28
1 files changed, 11 insertions, 17 deletions
diff --git a/profiles/workstation.nix b/profiles/workstation.nix
index acc04c5..e607c0d 100644
--- a/profiles/workstation.nix
+++ b/profiles/workstation.nix
@@ -43,34 +43,28 @@
 
   hardware.pulseaudio.enable = false;
 
+  # This is a good source of information about fonts:
+  # https://github.com/system-fonts/modern-font-stacks
   fonts = {
     enableDefaultFonts = true;
     fontDir.enable = true;
     fontconfig = {
       enable = true;
       defaultFonts = {
-        serif = [ "Bitstream Vera Serif" ];
-        sansSerif = [ "Bitstream Vera Sans" ];
-        monospace = [ "Bitstream Vera Sans Mono" ];
+        serif = [ "DejaVu Serif" ];
+        sansSerif = [ "Roboto" ];
+        monospace = [ "JetBrain Mono" ];
       };
     };
     fonts = with pkgs; [
+      cantarell-fonts
       dejavu_fonts
-      ttf_bitstream_vera
-
+      etBook
       font-awesome_5
-
-      noto-fonts
-      noto-fonts-cjk # Chinese, Japanese, Korean
-      noto-fonts-emoji
-      noto-fonts-emoji
-      noto-fonts-extra
-
-      cantarell-fonts
-
-      source-code-pro
-      source-sans-pro
-      source-serif-pro
+      google-fonts
+      jetbrains-mono
+      powerline-fonts
+      roboto
     ];
   };