about summary refs log tree commit diff
path: root/profiles/workstation.nix
diff options
context:
space:
mode:
Diffstat (limited to 'profiles/workstation.nix')
-rw-r--r--profiles/workstation.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/profiles/workstation.nix b/profiles/workstation.nix
index 484d110..e860389 100644
--- a/profiles/workstation.nix
+++ b/profiles/workstation.nix
@@ -3,4 +3,22 @@
   virtualisation.docker.enable = false;
   virtualisation.podman.enable = true;
   virtualisation.podman.dockerCompat = true;
+
+  services.dbus.enable = true;
+  services.dbus.packages = with pkgs; [ gcr dconf gnome.sushi ];
+  services.udev.packages = with pkgs; [ gnome3.gnome-settings-daemon ];
+
+  services.gvfs.enable = true;
+
+  programs.dconf.enable = true;
+
+  services.avahi.enable = true;
+  services.avahi.nssmdns = true;
+  services.avahi.openFirewall = true;
+
+  # for the yubikeys
+  services.pcscd.enable = true;
+
+  # Install tools related to the scanner (scanimage etc)
+  hardware.sane.enable = true;
 }