about summary refs log tree commit diff
path: root/profiles/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'profiles/default.nix')
-rw-r--r--profiles/default.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/profiles/default.nix b/profiles/default.nix
index 9cca61b..86fe4d8 100644
--- a/profiles/default.nix
+++ b/profiles/default.nix
@@ -24,6 +24,16 @@
 
   time.timeZone = "America/Los_Angeles";
 
+  # see https://www.man7.org/linux/man-pages/man5/loader.conf.5.html
+  boot.loader.systemd-boot.consoleMode = "max";
+
+  console = {
+    earlySetup = true;
+    font = "${pkgs.terminus_font}/share/consolefonts/ter-132n.psf.gz";
+    packages = with pkgs; [ terminus_font ];
+    keyMap = "us";
+  };
+
   security.sudo.wheelNeedsPassword = false;
   security.polkit.enable = true;