about summary refs log tree commit diff
path: root/packages/pizza/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'packages/pizza/default.nix')
-rw-r--r--packages/pizza/default.nix31
1 files changed, 0 insertions, 31 deletions
diff --git a/packages/pizza/default.nix b/packages/pizza/default.nix
deleted file mode 100644
index cf5e836..0000000
--- a/packages/pizza/default.nix
+++ /dev/null
@@ -1,31 +0,0 @@
-{ lib, python3 }:
-
-python3.pkgs.buildPythonApplication rec {
-  pname = "pizza";
-  src = ./pizza.py;
-  version = "0.1.0";
-  format = "other";
-
-  buildInputs = [ python3 ];
-  propagatedBuildInputs = with python3.pkgs; [
-    beautifulsoup4
-    prettytable
-    requests
-    termcolor
-  ];
-
-  dontUnpack = true;
-  dontBuild = true;
-
-  installPhase = ''
-    mkdir -p $out/bin
-    cp $src $out/bin/${pname}
-  '';
-
-  meta = with lib; {
-    description = "Get the pizza for the week for CheeseBoard.";
-    license = with licenses; [ mit ];
-    platforms = platforms.unix;
-    maintainers = with maintainers; [ fcuny ];
-  };
-}