about summary refs log tree commit diff
path: root/packages/dnsmasq-leases-html/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'packages/dnsmasq-leases-html/default.nix')
-rw-r--r--packages/dnsmasq-leases-html/default.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/packages/dnsmasq-leases-html/default.nix b/packages/dnsmasq-leases-html/default.nix
new file mode 100644
index 0000000..478c4cc
--- /dev/null
+++ b/packages/dnsmasq-leases-html/default.nix
@@ -0,0 +1,36 @@
+{ lib, stdenvNoCC, pkgs }:
+
+stdenvNoCC.mkDerivation rec {
+  pname = "dnsmasq-leases-html";
+  src = ./dnsmasq-leases-html.py;
+  templates = ./templates;
+  version = "0.1.0";
+
+  buildInputs = [
+    (pkgs.python310.withPackages (ps: with ps; [
+      jinja2
+    ]))
+  ];
+
+  propagatedBuildInputs = [
+    (pkgs.python310.withPackages (ps: with ps; [
+      jinja2
+    ]))
+  ];
+
+  dontUnpack = true;
+  dontBuild = true;
+
+  installPhase = ''
+    mkdir -p $out/bin
+    cp $src $out/bin/${pname}
+    cp -r $templates $out/bin/templates
+  '';
+
+  meta = with pkgs.lib; {
+    description = "CLI to generate a HTML page with dnsmasq leases.";
+    license = licenses.mit;
+    platforms = platforms.unix;
+    maintainers = [ ];
+  };
+}