about summary refs log tree commit diff
path: root/nix/users/fcuny/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/users/fcuny/shell.nix')
-rw-r--r--nix/users/fcuny/shell.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/nix/users/fcuny/shell.nix b/nix/users/fcuny/shell.nix
index cdc393d..399a1df 100644
--- a/nix/users/fcuny/shell.nix
+++ b/nix/users/fcuny/shell.nix
@@ -30,6 +30,7 @@ in {
       aspellDicts.en-science
     ] ++ (lib.optionals (isLinux) [ htop ]);
 
+  # https://github.com/nix-community/home-manager/blob/master/modules/programs/fish.nix
   programs.fish = {
     enable = true;
     interactiveShellInit = ''
@@ -44,15 +45,15 @@ in {
 
       set fish_greeting ""
     '';
-    shellAbbrs = { ncg = "nix-collect-garbage -d"; };
-    shellAliases = {
+    shellAbbrs = {
+      ncg = "nix-collect-garbage -d";
       c = "clear";
+    };
+    shellAliases = {
       ls = "eza -l -L=1 --git --color=always --group-directories-first";
       la = "eza -la --git --color=always --group-directories-first";
       ll = "eza -la -L=1 --git --color=always --group-directories-first";
       lt = "eza -aT -L=2 --git --color=always --group-directories-first";
-      k = "kubectl";
-      kctx = "kubie ctx";
     };
   };
 
@@ -80,7 +81,6 @@ in {
     enable = true;
     nix-direnv.enable = true;
     enableZshIntegration = true;
-    enableFishIntegration = true;
     config = {
       global.disable_stdin = true;
       global.strict_env = true;