about summary refs log tree commit diff
path: root/nix/users/fcuny/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/users/fcuny/shell.nix')
-rw-r--r--nix/users/fcuny/shell.nix17
1 files changed, 12 insertions, 5 deletions
diff --git a/nix/users/fcuny/shell.nix b/nix/users/fcuny/shell.nix
index d95c74d..e690437 100644
--- a/nix/users/fcuny/shell.nix
+++ b/nix/users/fcuny/shell.nix
@@ -1,7 +1,10 @@
 { config, pkgs, ... }:
-let isLinux = pkgs.stdenv.isLinux;
-in {
-  home.packages = with pkgs;
+let
+  isLinux = pkgs.stdenv.isLinux;
+in
+{
+  home.packages =
+    with pkgs;
     [
       # shell
       shellcheck
@@ -28,7 +31,8 @@ in {
       aspellDicts.en
       aspellDicts.en-computers
       aspellDicts.en-science
-    ] ++ (lib.optionals (isLinux) [ htop ]);
+    ]
+    ++ (lib.optionals (isLinux) [ htop ]);
 
   # https://github.com/nix-community/home-manager/blob/master/modules/programs/fish.nix
   programs.fish = {
@@ -65,7 +69,10 @@ in {
   programs.fd = {
     enable = true;
     hidden = true;
-    ignores = [ ".git/" ".direnv/" ];
+    ignores = [
+      ".git/"
+      ".direnv/"
+    ];
   };
 
   programs.direnv = {