about summary refs log tree commit diff
path: root/nix/users/fcuny/nixos.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/users/fcuny/nixos.nix')
-rw-r--r--nix/users/fcuny/nixos.nix12
1 files changed, 8 insertions, 4 deletions
diff --git a/nix/users/fcuny/nixos.nix b/nix/users/fcuny/nixos.nix
index 4cc80bd..a6c302f 100644
--- a/nix/users/fcuny/nixos.nix
+++ b/nix/users/fcuny/nixos.nix
@@ -1,4 +1,5 @@
-{ pkgs, ... }: {
+{ pkgs, ... }:
+{
   # add ~/.local/bin to PATH
   environment.localBinInPath = true;
 
@@ -8,10 +9,13 @@
   users.users.fcuny = {
     isNormalUser = true;
     home = "/home/fcuny";
-    extraGroups = [ "docker" "wheel" "podman" ];
+    extraGroups = [
+      "docker"
+      "wheel"
+      "podman"
+    ];
     shell = pkgs.fish;
-    hashedPassword =
-      "$6$U4GoqhuHgdr.h0JP$C/BKslQfOpPJ5lUzrTeQh6i859R/jEKYSF9MaRhWYo5VG6aCDKsvb5xKSifH4nQt6okJixG9ceFh..Mnt93Jt/";
+    hashedPassword = "$6$U4GoqhuHgdr.h0JP$C/BKslQfOpPJ5lUzrTeQh6i859R/jEKYSF9MaRhWYo5VG6aCDKsvb5xKSifH4nQt6okJixG9ceFh..Mnt93Jt/";
     openssh.authorizedKeys.keys = [
       # key `nixos` in 1password
       "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAINBkozy+X96u5ciX766bJ/AyQ3xm1tXZTIr5+4PVFZFi"