about summary refs log tree commit diff
path: root/nix/users/fcuny/k8s.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/users/fcuny/k8s.nix')
-rw-r--r--nix/users/fcuny/k8s.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/nix/users/fcuny/k8s.nix b/nix/users/fcuny/k8s.nix
new file mode 100644
index 0000000..01fb802
--- /dev/null
+++ b/nix/users/fcuny/k8s.nix
@@ -0,0 +1,33 @@
+{ pkgs, ... }: {
+  home.packages = with pkgs; [
+    kind # k8s in docker
+    kubebuilder # generate controller
+    kubectl
+    kubernetes-helm # deploy applications
+    kubie # kubeconfig browser https://github.com/sbstp/kubie
+    kubelogin-oidc # OIDC plugin
+    k9s # object explorer
+
+    # docker
+    dive # explore layers in docker images
+  ];
+
+  home.file.kubie = {
+    target = ".kube/kubie.yaml";
+    text = ''
+      shell: fish
+      configs:
+        include:
+          - ~/.kube/rksconfig
+      prompt:
+        fish_use_rprompt: true
+    '';
+  };
+
+  programs.fish = {
+    shellAliases = {
+      ukctx = ''
+        ${pkgs.gh}/bin/gh api "repos/Roblox/prophase/contents/path/to/file" --jq '.content' | base64 -d > ~/.kube/rksconfig'';
+    };
+  };
+}