about summary refs log tree commit diff
path: root/nix/profiles/home-manager/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/profiles/home-manager/shell.nix')
-rw-r--r--nix/profiles/home-manager/shell.nix51
1 files changed, 43 insertions, 8 deletions
diff --git a/nix/profiles/home-manager/shell.nix b/nix/profiles/home-manager/shell.nix
index 2c22880..936d34b 100644
--- a/nix/profiles/home-manager/shell.nix
+++ b/nix/profiles/home-manager/shell.nix
@@ -55,15 +55,50 @@
     ASPELL_CONF = "conf ${config.xdg.configHome}/aspell/config;";
   };
 
-  programs = {
-    direnv = {
-      enable = true;
-      nix-direnv.enable = true;
-      enableZshIntegration = true;
-      config = {
-        global.disable_stdin = true;
-        global.strict_env = true;
+  programs.alacritty = {
+    enable = true;
+    settings = {
+      env = {
+        TERM = "xterm-256color";
       };
+      shell = {
+        program = "${pkgs.fish}/bin/fish";
+        args = [
+          "-c"
+          "tmux attach -t base || tmux new -s base"
+        ];
+      };
+      font = {
+        normal.family = "Monaspace Argon";
+        bold = { style = "Bold"; };
+        size = 18;
+      };
+    };
+  };
+
+  programs.tmux = {
+    enable = true;
+    terminal = "xterm-256color";
+    escapeTime = 0;
+    aggressiveResize = true;
+    baseIndex = 1;
+    shortcut = "z";
+    clock24 = true;
+    historyLimit = 50000; # Bigger buffer
+    extraConfig = ''
+      setw -g mouse on
+
+      set-option -g renumber-windows on
+    '';
+  };
+
+  programs.direnv = {
+    enable = true;
+    nix-direnv.enable = true;
+    enableZshIntegration = true;
+    config = {
+      global.disable_stdin = true;
+      global.strict_env = true;
     };
   };
 }