about summary refs log tree commit diff
path: root/nix/profiles/home-manager/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/profiles/home-manager/shell.nix')
-rw-r--r--nix/profiles/home-manager/shell.nix49
1 files changed, 49 insertions, 0 deletions
diff --git a/nix/profiles/home-manager/shell.nix b/nix/profiles/home-manager/shell.nix
new file mode 100644
index 0000000..3869d9b
--- /dev/null
+++ b/nix/profiles/home-manager/shell.nix
@@ -0,0 +1,49 @@
+{ pkgs, self, ... }: {
+
+  home.packages = with pkgs; [
+    # shell utils
+    direnv
+    ripgrep
+    tree
+    wget
+
+    # data manipulation
+    jless
+    jq
+    yq
+
+    # nix related
+    nil
+    nix-direnv
+    nixd
+    nixfmt
+    nixpkgs-fmt
+    rnix-lsp
+
+    # my own stuff
+    self.packages.${pkgs.system}.git-blame-stats
+    self.packages.${pkgs.system}.git-broom
+    self.packages.${pkgs.system}.ipconverter
+    self.packages.${pkgs.system}.seqstat
+  ];
+
+  home.sessionVariables = {
+    EDITOR = "emacsclient -a=";
+    VISUAL = "emacsclient -a=";
+    LESS = "-FRSXM";
+    LESSCHARSET = "utf-8";
+    PAGER = "less";
+  };
+
+  programs = {
+    direnv = {
+      enable = true;
+      nix-direnv.enable = true;
+      enableZshIntegration = true;
+      config = {
+        global.disable_stdin = true;
+        global.strict_env = true;
+      };
+    };
+  };
+}