about summary refs log tree commit diff
path: root/nix/mkHomeManagerConfiguration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/mkHomeManagerConfiguration.nix')
-rw-r--r--nix/mkHomeManagerConfiguration.nix45
1 files changed, 0 insertions, 45 deletions
diff --git a/nix/mkHomeManagerConfiguration.nix b/nix/mkHomeManagerConfiguration.nix
deleted file mode 100644
index 38bc19f..0000000
--- a/nix/mkHomeManagerConfiguration.nix
+++ /dev/null
@@ -1,45 +0,0 @@
-inputs@{ self, ... }:
-{ system ? "x86_64-linux"
-, username ? "fcuny"
-, hostname
-, stateVersion ? "22.11"
-,
-}:
-let
-  naersk = inputs.naersk.lib."${system}";
-in
-inputs.home-manager.lib.homeManagerConfiguration {
-  modules = [
-    "${self}/hosts/${hostname}/home.nix"
-    {
-      home = {
-        username = username;
-        homeDirectory = "/home/${username}";
-        stateVersion = stateVersion;
-      };
-      homeage = {
-        identityPaths = [ "~/.age/key.txt" ];
-        installationType = "activation";
-        mount = "/home/${username}/.secrets";
-      };
-      imports = [ inputs.homeage.homeManagerModules.homeage ];
-    }
-  ];
-
-  extraSpecialArgs = { inherit inputs self; };
-
-  pkgs = import inputs.nixpkgs {
-    inherit system;
-    config.allowUnfree = true;
-    overlays = [
-      inputs.emacs-overlay.overlay
-      inputs.nur.overlay
-      inputs.naersk.overlay
-      inputs.rust.overlays.default
-      (final: prev:
-        {
-          tools = import "${self}/tools" { pkgs = prev; inherit naersk; };
-        })
-    ];
-  };
-}