about summary refs log tree commit diff
path: root/nix/machines/vm-shared.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/machines/vm-shared.nix')
-rw-r--r--nix/machines/vm-shared.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/nix/machines/vm-shared.nix b/nix/machines/vm-shared.nix
index bf26f38..0a1b4b2 100644
--- a/nix/machines/vm-shared.nix
+++ b/nix/machines/vm-shared.nix
@@ -13,8 +13,6 @@
   boot.loader.systemd-boot.enable = true;
   boot.loader.efi.canTouchEfiVariables = true;
 
-  networking.hostName = "dev";
-
   time.timeZone = "America/Los_Angeles";
 
   # Don't require password for sudo
@@ -38,6 +36,10 @@
   services.openssh.settings.PasswordAuthentication = true;
   services.openssh.settings.PermitRootLogin = "no";
 
+  users.users.root.openssh.authorizedKeys.keys = [
+    "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAINBkozy+X96u5ciX766bJ/AyQ3xm1tXZTIr5+4PVFZFi"
+  ];
+
   networking.firewall.enable = false;
 
   # This value determines the NixOS release from which the default