about summary refs log tree commit diff
path: root/nix/hosts/nixos/user.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/hosts/nixos/user.nix')
-rw-r--r--nix/hosts/nixos/user.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/nix/hosts/nixos/user.nix b/nix/hosts/nixos/user.nix
new file mode 100644
index 0000000..b358d3e
--- /dev/null
+++ b/nix/hosts/nixos/user.nix
@@ -0,0 +1,12 @@
+{ ... }:
+{
+  users.users.fcuny = {
+    uid = 1000;
+    isNormalUser = true;
+    extraGroups =
+      [
+        "wheel"
+        "dialout" # Enable access to serial devices
+      ];
+  };
+}