about summary refs log tree commit diff
path: root/nix/flake/hosts.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/flake/hosts.nix')
-rw-r--r--nix/flake/hosts.nix11
1 files changed, 10 insertions, 1 deletions
diff --git a/nix/flake/hosts.nix b/nix/flake/hosts.nix
index 8e9316a..c2ba71b 100644
--- a/nix/flake/hosts.nix
+++ b/nix/flake/hosts.nix
@@ -7,7 +7,16 @@ let
     darwin.lib.darwinSystem {
       inherit system;
       modules = [
-        home-manager.darwinModule
+        home-manager.darwinModules.home-manager
+        {
+          home-manager = {
+            useGlobalPkgs = true;
+            useUserPackages = true;
+            extraSpecialArgs = {
+              inherit self;
+            };
+          };
+        }
         ../../hosts/common/darwin/homebrew.nix
         ../../hosts/common/darwin/macos.nix
         path