about summary refs log tree commit diff
path: root/nix/checks.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/checks.nix')
-rw-r--r--nix/checks.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/nix/checks.nix b/nix/checks.nix
new file mode 100644
index 0000000..aadb170
--- /dev/null
+++ b/nix/checks.nix
@@ -0,0 +1,31 @@
+{ pkgs, pre-commit-hooks, ... }:
+
+with pkgs;
+
+{
+  pre-commit-check = pre-commit-hooks.lib.${system}.run {
+    src = lib.cleanSource ../.;
+    hooks = {
+      nix-linter.enable = true;
+      nixpkgs-fmt.enable = true;
+      trailing-whitespace = {
+        enable = true;
+        entry =
+          "${pkgs.python3Packages.pre-commit-hooks}/bin/trailing-whitespace-fixer";
+        types = [ "text" ];
+      };
+      end-of-file-fixer = {
+        enable = true;
+        entry =
+          "${pkgs.python3Packages.pre-commit-hooks}/bin/end-of-file-fixer";
+        types = [ "text" ];
+      };
+      terraform-format = { enable = true; };
+      shellcheck = {
+        enable = true;
+        files = "\\.sh$";
+        types_or = [ "file" ];
+      };
+    };
+  };
+}