about summary refs log tree commit diff
path: root/modules/system/boot/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/system/boot/default.nix')
-rw-r--r--modules/system/boot/default.nix12
1 files changed, 0 insertions, 12 deletions
diff --git a/modules/system/boot/default.nix b/modules/system/boot/default.nix
index 30030c6..b223336 100644
--- a/modules/system/boot/default.nix
+++ b/modules/system/boot/default.nix
@@ -10,18 +10,6 @@ in
 
   config = {
     boot = {
-      loader = {
-        # Use the systemd-boot EFI boot loader.
-        systemd-boot.enable = true;
-        # Prohibits gaining root access by passing init=/bin/sh as a kernel parameter
-        systemd-boot.editor = false;
-        efi.canTouchEfiVariables = true;
-      };
-
-      kernelPackages = pkgs.linuxPackages_latest;
-      cleanTmpDir = true;
-      tmpOnTmpfs = true;
-
       initrd = {
         network = lib.mkIf cfg.initrd.network.enable {
           enable = true;