about summary refs log tree commit diff
path: root/modules/system/boot/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/system/boot/default.nix')
-rw-r--r--modules/system/boot/default.nix31
1 files changed, 0 insertions, 31 deletions
diff --git a/modules/system/boot/default.nix b/modules/system/boot/default.nix
deleted file mode 100644
index b223336..0000000
--- a/modules/system/boot/default.nix
+++ /dev/null
@@ -1,31 +0,0 @@
-{ pkgs, config, lib, ... }:
-let cfg = config.my.system.boot;
-in
-{
-  options.my.system.boot = with lib; {
-    initrd = {
-      network = { enable = mkEnableOption "enable SSH with initrd"; };
-    };
-  };
-
-  config = {
-    boot = {
-      initrd = {
-        network = lib.mkIf cfg.initrd.network.enable {
-          enable = true;
-          postCommands = ''
-            echo "cryptsetup-askpass; exit" > /root/.profile
-          '';
-          ssh = {
-            enable = true;
-            port = 2222;
-            hostKeys =
-              [ /etc/ssh/ssh_host_ed25519_key /etc/ssh/ssh_host_rsa_key ];
-            authorizedKeys =
-              config.users.users.fcuny.openssh.authorizedKeys.keys;
-          };
-        };
-      };
-    };
-  };
-}