about summary refs log tree commit diff
path: root/modules/services/syncthing/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/services/syncthing/default.nix')
-rw-r--r--modules/services/syncthing/default.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/modules/services/syncthing/default.nix b/modules/services/syncthing/default.nix
index ea8c4d6..19f0c62 100644
--- a/modules/services/syncthing/default.nix
+++ b/modules/services/syncthing/default.nix
@@ -16,6 +16,24 @@ in {
       dataDir = "/home/fcuny/.local/state/syncthing";
       cert = secrets."syncthing/cert".path;
       key = secrets."syncthing/key".path;
+
+      folders.Sync = {
+        path = "/home/fcuny/documents";
+        devices = attrNames config.services.syncthing.devices;
+      };
+
+      devices = {
+        aptos = {
+          id =
+            "JAN5UMH-2FAQQ7S-KLQ2YXM-C7KKK7U-HVHUK7I-CWOZQRM-VLQSO63-ZTP4WAN";
+          introducer = false;
+        };
+        tahoe = {
+          id =
+            "4Y36C3Y-LUTO6LD-JXNV73B-FLXSTNP-5Q3CSPY-HESHTPH-EDYA54K-WEICJAJ";
+          introducer = true;
+        };
+      };
     };
   };
 }