about summary refs log tree commit diff
path: root/modules/services/monitoring/promtail.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/services/monitoring/promtail.nix')
-rw-r--r--modules/services/monitoring/promtail.nix65
1 files changed, 0 insertions, 65 deletions
diff --git a/modules/services/monitoring/promtail.nix b/modules/services/monitoring/promtail.nix
deleted file mode 100644
index 85d34dc..0000000
--- a/modules/services/monitoring/promtail.nix
+++ /dev/null
@@ -1,65 +0,0 @@
-{ config, lib, pkgs, ... }:
-let
-  cfg = config.my.services.monitoring.promtail;
-in
-{
-  options.my.services.monitoring.promtail = with lib; {
-    enable = mkEnableOption "promtail logs exporter";
-  };
-
-  config = lib.mkIf cfg.enable {
-    services.promtail = {
-      enable = true;
-      configuration = {
-        clients = [{ url = "http://192.168.6.40:3100/loki/api/v1/push"; }];
-        scrape_configs = [
-          {
-            job_name = "journal";
-            journal = {
-              json = true;
-              path = "/var/log/journal";
-              max_age = "12h";
-              labels = {
-                host = config.networking.hostName;
-                job = "journal";
-                "__path__" = "/var/log/journal";
-              };
-            };
-
-            relabel_configs = [
-              {
-                source_labels = [ "__journal__systemd_unit" ];
-                target_label = "unit";
-              }
-              {
-                source_labels = [ "__journal_priority" ];
-                target_label = "priority";
-              }
-              {
-                source_labels = [ "__journal_syslog_identifier" ];
-                target_label = "syslog_id";
-              }
-            ];
-          }
-
-          {
-            job_name = "nginx";
-            static_configs = [{
-              labels = {
-                host = config.networking.hostName;
-                job = "nginx";
-                __path__ = "/var/log/nginx/*";
-              };
-            }];
-          }
-        ];
-
-        server = {
-          http_listen_port = 9832;
-          http_path_prefix = "/promtail";
-          grpc_listen_port = 0;
-        };
-      };
-    };
-  };
-}