about summary refs log tree commit diff
path: root/modules/hardware/amd/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/hardware/amd/default.nix')
-rw-r--r--modules/hardware/amd/default.nix14
1 files changed, 0 insertions, 14 deletions
diff --git a/modules/hardware/amd/default.nix b/modules/hardware/amd/default.nix
deleted file mode 100644
index e8b80b0..0000000
--- a/modules/hardware/amd/default.nix
+++ /dev/null
@@ -1,14 +0,0 @@
-{ config, lib, ... }:
-let cfg = config.my.hardware.amd;
-in
-{
-  options.my.hardware.amd = with lib; {
-    enable = mkEnableOption "AMD related configuration";
-  };
-
-  config = lib.mkIf cfg.enable {
-    # Enable microcode update
-    hardware.cpu.amd.updateMicrocode = true;
-    boot.kernelModules = [ "kvm-amd" ];
-  };
-}