about summary refs log tree commit diff
path: root/modules/hardware/amd/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/hardware/amd/default.nix')
-rw-r--r--modules/hardware/amd/default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/modules/hardware/amd/default.nix b/modules/hardware/amd/default.nix
new file mode 100644
index 0000000..05362db
--- /dev/null
+++ b/modules/hardware/amd/default.nix
@@ -0,0 +1,13 @@
+{ config, lib, ... }:
+let cfg = config.my.hardware.amd;
+in {
+  options.my.hardware.amd = with lib; {
+    enable = mkEnableOption "AMD related configuration";
+  };
+
+  config = lib.mkIf cfg.enable {
+    # Enable microcode update
+    hardware.cpu.amd.updateMicrocode = true;
+    boot.kernelModules = [ "kvm-amd" ];
+  };
+}