about summary refs log tree commit diff
path: root/modules/desktop/fonts.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/desktop/fonts.nix')
-rw-r--r--modules/desktop/fonts.nix33
1 files changed, 20 insertions, 13 deletions
diff --git a/modules/desktop/fonts.nix b/modules/desktop/fonts.nix
index a840582..367e42e 100644
--- a/modules/desktop/fonts.nix
+++ b/modules/desktop/fonts.nix
@@ -1,18 +1,25 @@
-{ pkgs, config, lib, ... }:
+{pkgs, config, lib, ... }:
+with lib;
 
-{
-  fonts = {
-    fontconfig.enable = true;
-    fonts = with pkgs; [
-      noto-fonts-emoji
-      dejavu_fonts
-      source-code-pro
-      source-sans-pro
-      source-serif-pro
-    ];
+let
+  xorg = (elem "xorg" config.sys.graphics.desktopProtocols);
+  wayland = (elem "wayland" config.sys.graphics.desktopProtocols);
+  desktopMode = xorg || wayland;
+in {
+  config= mkIf desktopMode {
+    fonts = {
+      fontconfig.enable = true;
+      fonts = with pkgs; [
+        noto-fonts-emoji
+        dejavu_fonts
+        source-code-pro
+        source-sans-pro
+        source-serif-pro
+      ];
 
-    fontconfig.defaultFonts = {
-      monospace = [ "Source Code Pro" ];
+      fontconfig.defaultFonts = {
+        monospace = [ "Source Code Pro" ];
+      };
     };
   };
 }