about summary refs log tree commit diff
path: root/hosts/tahoe/services.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/tahoe/services.nix')
-rw-r--r--hosts/tahoe/services.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/hosts/tahoe/services.nix b/hosts/tahoe/services.nix
new file mode 100644
index 0000000..a8badea
--- /dev/null
+++ b/hosts/tahoe/services.nix
@@ -0,0 +1,37 @@
+{ ... }:
+
+{
+  my.services = {
+    samba = {
+      enable = true;
+      publicShares = [ "/data/fast/music" "/data/fast/videos" ];
+    };
+    navidrome = {
+      enable = true;
+      musicFolder = "/data/fast/music";
+    };
+    unifi = { enable = true; };
+    prometheus = { enable = true; };
+    grafana = { enable = true; };
+    gitea = {
+      enable = true;
+      stateDir = "/var/lib/gitea";
+    };
+    rclone = { enable = true; };
+    traefik = { enable = true; };
+    transmission = { enable = true; };
+    metrics-exporter = { enable = true; };
+  };
+
+  services.restic.backups = {
+    media = {
+      paths = [ "/data/fast/music" "/data/fast/photos" "/data/fast/videos" ];
+      repository = "/data/slow/backups/systems";
+      passwordFile = config.age.secrets.restic-repo-systems.path;
+      timerConfig = { OnCalendar = "00:55"; };
+      initialize = true;
+      extraBackupArgs = [ "--tag media" ];
+      pruneOpts = [ "--keep-daily 7" "--keep-weekly 4" "--keep-monthly 12" ];
+    };
+  };
+}