about summary refs log tree commit diff
path: root/hosts/tahoe/secrets/secrets.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/tahoe/secrets/secrets.nix')
-rw-r--r--hosts/tahoe/secrets/secrets.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/hosts/tahoe/secrets/secrets.nix b/hosts/tahoe/secrets/secrets.nix
new file mode 100644
index 0000000..d6b7272
--- /dev/null
+++ b/hosts/tahoe/secrets/secrets.nix
@@ -0,0 +1,14 @@
+let
+  fcuny_aptos =
+    "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIIdlm/qoR/dnMjZhVSTtqFzkgN3Yf9eQ3pgKMiipg+dl";
+in {
+  "wireguard_privatekey.age".publicKeys = [ fcuny_aptos ];
+
+  "traefik/gcp_service_account.json.age".publicKeys = [ fcuny_aptos ];
+
+  "unifi/unifi-poller.age".publicKeys = [ fcuny_aptos ];
+
+  "restic/repo-systems.age".publicKeys = [ fcuny_aptos ];
+  "rclone/config.ini.age".publicKeys = [ fcuny_aptos ];
+  "rclone/gcs_service_account.json.age".publicKeys = [ fcuny_aptos ];
+}