about summary refs log tree commit diff
path: root/hosts/tahoe/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/tahoe/default.nix')
-rw-r--r--hosts/tahoe/default.nix21
1 files changed, 1 insertions, 20 deletions
diff --git a/hosts/tahoe/default.nix b/hosts/tahoe/default.nix
index 5a746dd..9d11720 100644
--- a/hosts/tahoe/default.nix
+++ b/hosts/tahoe/default.nix
@@ -3,31 +3,12 @@
 {
   imports = [ # Include the results of the hardware scan.
     ./hardware-configuration.nix
+    ./networking.nix
     ../profiles/nas.nix
-    ../common/system/tailscale.nix
   ];
 
   boot = { initrd = { luks.devices."system".allowDiscards = true; }; };
 
-  # Use systemd-networkd for networking
-  systemd.network = {
-    enable = true;
-    networks = {
-      enp42s0 = {
-        matchConfig.Name = "enp42s0";
-        networkConfig = { DHCP = "yes"; };
-        extraConfig = ''
-          [DHCPv4]
-          UseDNS=yes
-          UseDomains=yes
-        '';
-      };
-    };
-  };
-
-  networking.private-wireguard.enable = true;
-  networking.firewall.enable = false;
-
   # This value determines the NixOS release from which the default
   # settings for stateful data, like file locations and database versions
   # on your system were taken. It‘s perfectly fine and recommended to leave